C und C++-Entwicklung mit Eclipse und CDT

Aus LaborWiki
Wechseln zu: Navigation, Suche
C und C++-Entwicklung mit Eclipse und CDT
Akteur
Akteur Email
Akteur URL
Beginn 2010/08/09 19:00:00
Ende
Ort LABOR e.V., Alleestr. 50, 44793 Bochum
Verantwortlich
Publikum
Schlagworte
Art workshop
Rahmenveranstaltung
Export iCalendar-Datei
Kurzbeschreibung: Dieser Workshop stellt die Entwicklungsumgebung Eclipse in Verbindung

mit dem CDT-Plugin vor und führt in grundlegende Konzepte dieser IDE

ein.


Thema[Bearbeiten]

Dieser Workshop stellt die Entwicklungsumgebung Eclipse in Verbindung mit dem CDT-Plugin vor und führt in grundlegende Konzepte dieser IDE ein. Er richtet sich an C/C++-Entwickler, die zuvor noch nie mit Eclipse gearbeitet haben.

Gegenstand[Bearbeiten]

Folgende Themen werden Gegenstand des Workshops sein

  • Installation (nur grob, siehe Vorkenntnisse) unter Linux und Windows
  • Grundlegende Bedienkonzepte von Eclipse
  • Projektverwaltung
  • Build-System
  • erweiterte Editorfunktionen und Eingabehilfen für Quelltexte
  • Navigation in großen Projekten
  • Aufgabenverwaltung und Lesezeichen
  • Einbindung von SVN (Subclipse)
  • Debugging

Sonstiges[Bearbeiten]

Bzgl. der Vorkenntnisse sollten die Teilnehmer in der Lage sein, selbständig ein Java Runtime Environment (JRE) sowie eine GCC-Toolchain auf ihrem System zu installieren (wobei letzteres unter Windows mittels Cygwin bzw. MinGW32 etwas knifflig werden kann). Idealerweise sollte dies vor dem Workshop geschehen. Dieser Workshop führt explizit NICHT in die Sprachen C und C++ ein.

Verwendet wird Eclipse 3.6 mit dem CDT-Plugin 7.0. Es gibt ein vorgefertigtes Paket für C/C++-Entwickler, das unter folgender URL bezogen werden kann:

http://www.eclipse.org/downloads/packages/eclipse-ide-cc-developers/heliosr

Wer selbst in der Lage ist, Eclipse und CDT in den angegebenen Versionen auf seinem System zu installieren, möge dies bitte tun, damit wir schneller zu den interessanten Themen kommen können. Ich werde bereits um 18:00 Uhr im Labor sein, um dem einen oder anderen bei kleineren Installationsproblemen unter die Arme zu greifen.

svn-URL für borgware-2d[Bearbeiten]

https://www.das-labor.org/svn/microcontroller/src-atmel/borg/borgware-2d

Pakete für cygwin[Bearbeiten]

Wer unter Windows arbeitet, benötigt die Cygwin-Umgebung, um die borgware-2d zu bauen. Folgende Pakete werden gebraucht:

  • make
  • gcc
  • g++
  • gdb
  • opengl
  • libncurses-devel

Der Pfad zu den Cywin-Binaries sollte in der Path-Umgebungsvariable eingetragen sein.